|
。3)配置VLAN Trunks
Switch# configure terminal
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
附:switchport trunk encapsulation {isl dot1q negotiate} // 配置trunk封裝ISL 或 802.1Q 或自動協(xié)商
switchport mode {dynamic {auto desirable} trunk} (一般不用它),配置二層trunk模式。(dynamic auto—自動協(xié)商是否成為trunk;dynamic desirable—把端口設(shè)置為trunk如果對方端口是trunk, desirable, 或自動模式;trunk—設(shè)置端口為強制的trunk方式,而不理會對方端口是否為trunk)
。4)定義trunk允許的VLAN
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2 // 配置trunk允許的VLAN
Switch(config-if)# end
附:switchport trunk allowed vlan {add all except remove} vlan-list
。5)配置Native VLAN(802.1q)
switch(config-if)# switchport trunk native vlan-num // 封裝802.1q的trunk端口可以接受帶有標簽和不帶標簽的數(shù)據(jù)流,交換機向native vlan傳送不帶標簽的數(shù)據(jù)流,缺省情況下native VLAN是VLAN 1
使用no switchport trunk native vlan 端口配置命令回到缺省的狀態(tài)
。6)配置一組端口
4006# configure terminal
4006(config)# interface range fastethernet2/1 – 5
4006(config-if-range)# no shutdown
// 注意:端口號之間需要加入空格,如:interface range fastethernet 2/1 – 5 是有效的,而interface range fastethernet 2/1-5 是無效的.
以下的例子顯示使用逗號來配置不同類型端口的組:
4006# configure terminal
4006(config)# interface range fastethernet2/1 – 3, gigabitethernet3/1 - 2
4006(config-if-range)# no shutdown
。7)其它常用命令
duplex {auto full half} // 設(shè)置全雙工或半雙工.
speed {10 100 1000 auto nonegotiate} 設(shè)置端口速率 // 注:1000 只工作在千兆口. GBIC模塊只工作在1000 Mbps下. nonegotiate 只能在這些GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.
copy running-config startup-config // 保存設(shè)置
(8)配置EtherChannel
以太通道捆綁幾個以太端口為一個獨立的邏輯鏈路。如4006交換機,你可以捆綁在4006任何模塊上最多8個兼容的具有相同速率的端口。每個以太通道具有一個port-channel端口號。要捆綁一個以太通道時,會產(chǎn)生一個邏輯port-channel端口,邏輯端口下的配置可影響與之捆綁的物理端口,但物理端口下的配置不能影響邏輯端口的配置。
1) 三層以太通道(邏輯port-channe)的配置
Switch# configure terminal
Switch(config)# interface port-channel 1 // 創(chuàng)建一個邏輯端口
Switch(config-if)# ip address 172.32.52.10 255.255.255.0
Switch(config-if)# end
2) 三層物理端口配置
Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 – 5 (注意: 空格是必需的)
Switch(config-if)# no switchport // 改變該端口為三層接口
Switch(config-if)# no ip address // 確認接口沒有配置IP地址
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end
附: Switch(config-if)# channel-group port_channel_number mode {auto desirable on} // 將該物理端口加入一個以太通道中,并確定PagP模式。
3) 二層以太通道配置
Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (注意: 空格是必需的)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
Switch# show running-config interface port-channel 2
Building configuration...
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
Switch# |
|
【收藏】【打印】【進入論壇】 |
|
|
|
|
|
|
|